Phasing Out Support for Internet Explorer 8

Contributed By

Dylan Rodgers

Content Strategy Manager and Editor in Chief of the Schoology Exchange

Phasing Out Support for Internet Explorer 8

Posted in Schoology | June 24, 2013

In this quickly-paced technological world of ours, upgrading to newer, better versions of software and cloudware is imperative to supporting innovative tools and improved security standards. So in order to continue providing the best online academic experience possible, we are discontinuing support for Internet Explorer 8 (IE8) starting January 1, 2014.

All of the platform's existing features will continue to work on IE8 after the phase-out date; however, all upgrades and new features released after the phase-out will not be built to run on IE8. So if you use IE8, we strongly suggest that you upgrade to the latest version of Internet Explorer, Google Chrome, or Mozilla Firefox.

If you have any questions, don't hesitate to contact our Support Team via our community forum.

Join the Conversation